KpyM Telnet/SSH Server - Forum
shell is dead
tkmoult shell is dead
 
After login, the connection is closed, I find the following in the log file:

KTS connected to 192.168.0.2:1085
term-ssh.exe started
connected to 192.168.0.2:1085
ssh initialized
login accepted: [ ralph ]
shell is dead
term-ssh.exe end


Kroum Grigorov
 
It seems like after KTS spawns the shell, for some reason it instantly exits.
Check your [KTerm]:shell_command parameter. It should be:
shell_command="%COMSPEC% /K "scripts\__shell.bat""
This executes __shel.bat and then leaves cmd.exe running.
If it is OK, you can try setting shell_command to the full path of cmd.exe:
shell_command=c:\winnt\system32\cmd.exe
(it might be different on your machine)

Krum


tkmoult
 
Did the above, no change in behavior. I can see cmd.exe pop up on my process list under the correct user after login, but then I get disconnected, cmd.exe drops of the process list, and I get the same log message. It was working correctly, but I don't know what I did to break it. I've tried to remove and re-install and that didn't work, I think my problem is outside of KTS? Dropping the firewall doesn't change any thing.


Kroum Grigorov
 
Check if you don't have some bizarre restriction on cmd.exe.
For example "Disable command prompt policy" or might be some kiosk process that monitors and kills cmd.exe.
Also check if the logged in user has sufficient rights to execute cmd.exe file.

Another check you can do is to change shell_command to say c:\winnt\system32\ftp.exe
If ftp process is started, definitely there is some restriction on cmd.exe in your system.


 

© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group