KpyM Telnet/SSH Server - Forum
Command via KpyM telnet fail, same command local work, why?
John Command via KpyM telnet fail, same command local work, why?
I am running Windows 10 and since MS no longer offers a telnet server I installed KpyM Telnet server (thanks for creating it!) so I can log in to the Win10 machine remotely.

On this Win10 machine I have some VirtualBox VMs that I start automatically when the machine starts.

I want to be able to shut down these VMs via KpyM Telnet. On a KpyM Telnet session I enter this command:

"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" controlvm vm savestate

but it fails and I get this:

Files\Oracle\VirtualBox\VBoxManage.exe" controlvm vm savestate
VBoxManage.exe: error: Machine 'vm' is not currently running

The same command on a DOS prompt on the Win10 machine works fine and the VM stops.

Why does this command fail via KpyM Telnet? Can I fix it or configure something to get this command to execute?

It seems native DOS command work OK from KpyM Telnet like "SHUTDOWN -s" for example woks and powers down the Win10 machine.

Also, I cannot run some test BAT scripts I created . I created a BAT file named list.bat (all that's in it is DIR) but this does not run either via the KpyM. It works on local DOS prompt. I'd like to have a BAT file I can run via KpyM that shuts down the VM then calls SHUTDOWN -s to shutdown the machine. Will I be able to do this with KpyM?


© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group