KpyM Telnet/SSH Server - Forum
Less, GREP, PowerShell problems
Zion City Less, GREP, PowerShell problems
Hi there,
I have less, grep, sed and some other tools installed on my computer. Precompiled for windows of course.
Unfortunately when I pipe to some of them, nothing is appearing on the Terminal. Tried with PuTTy, with OpenSSH client, and with some other clients. Nothing works.
However, when I do enable Pipe_mode in KpyM,less is sending a bunch of lines, but concatenated, Not on a new line, and I can not see what I am typing.
PowerShell don't work at all. I can get the prompt, but not the output.
Am I doing something wrong here, or it is simply a question of settings. Thank you.

Zion City
Tried Less with Telnet Service on Windows2003, and the output is pretty decent.
So I guess the problem is in the SSHD/Telnet implementation or in the settings.

Kroum Grigorov
>when I do enable Pipe_mode in KpyM
Pipe mode is there for automating scripting only, it does not produce decent output. Pipe mode is just a STDIN/STDOUT redirection to your client without any further "telnet" processing so this looks pretty bad.
Also pipe mode will not work with "console graphic" apps, for example as these do not support STDOUT redirection as they write directly to console screen buffer.

>I have less, grep, sed and some other tools installed
I've been playing with *nix tools ports in the past and in general most of these manipulate the console in a way that KTS implementation is incompatible with.



© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group