KpyM Telnet/SSH Server - Forum
Elevated Mode on W2K8 R2
Vahan Elevated Mode on W2K8 R2
 
Doesn't look like the command shell that's launched on W2K8 R2 is in elevated mode.

Is there a way to achieve this?

Thanks much!
-v


Kroum Grigorov
 
Nope, no solution for the moment.
You have to either disable UAC -or- live with its restrictions.

Kroum


Vahan
 
Thanks Kroum!

-v


Vahan
 
Btw, couldn't even get it to work after disabling UAC in the registry:

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA

if anyone was successful at this, please advise.

Thanks!
v


Kroum Grigorov
 
This works for me, following the instructions from this page
http://technet.microsoft.com/en-us/library/cc709691(WS.10).aspx

This is under the "To turn off UAC" section, do not forget to restart your machine to apply the change.

Kroum


Justin Dunlap
 
This is as easy as pie to fix. Add the following after calling ::LogonUser() in the KSession::LogonUser1() method:

DWORD dwLength;
GetTokenInformation(this->token, _TOKEN_INFORMATION_CLASS::TokenLinkedToken, &this->token, sizeof(HANDLE), &dwLength);

Boom! All user logins that are capable of being elevated will be elevated. I have not tested this with users that are not in the administrators group, so I don't know if maybe there should be a conditional around it to check for that first.


 

© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group