KpyM Telnet/SSH Server - Forum
italian keyboard layout2
rob italian keyboard layout2
 
Hello everybody!

Fist of all congratulations to the author of this piece of software, the only open source ssh server for Windows!

Now let me ecplain my problem in a more detailed way.

I installed the KpyM SSh server on a Win XP PRO - Italian version machine in order to access a DOS program (the UNESCO CDS/ISIS retrival sw, downloadable at the URL http://www.unesco.org/isis/files/winisis/dos/isisdos.zip).
I use putty as client and an (AT) Italian keyboard.

Using the following settings:
- KypM telnet.ini (export_code_page="437")
- KypM utf-8.ini unchanged
- KypM alluser.bat (with "chcp 437")
- putty charset translation -> CP437
allows me, just after the login, to type an to display correctly all the ASCII chars except the Italian specific chars (ASCII codes 130,133,138,141,149,151). But when I launch the CDS/ISIS DOS program most of the not alphabetical signs are not mapped correctly anymore.

Using the following settings:
- KypM telnet.ini (export_code_page="65001)
- KypM utf-8.ini unchanged
- KypM alluser.bat (with "chcp 65001")
- putty charset translation -> UTF-8
leads to similar results, just remapping the keyboard in a different way.

So I tried to remap the keyboard according to the application (CDS/ISIS DOS program), but in both cases (using CP437 and UNICODE) I was not able to remap some symbols, among others the "?" (question mark sign) and the Italian specific chars. I tried to get the codes using k_map.exe (http://www.kpym.com/download/k_map.exe), but without solving the issue.
Is there any way to overcome this problem?

Thanks in advance,
rob




I modified this telnet.ini parameter:
export_code_page = "65001"
I set the he modified this telnet.ini parameter:

I use putty (UTF-8 character translation)

Just after the


Kroum Grigorov
 
OK, this is what I tested and it seems to work on Windows XP
1) reinstall KTS, you do not need extra key mapings
2) set KTS export code page to 65001
3) in putty set tranlation to UTF-8
4) log in your KTS host
5) in your session type
kb16 it
this should switch your keyboard layout to italian(on your client machine you should have your keyboard layout to EN)
6) run your CDS/ISIS DOS, you should be able to type in italian



Kroum


rob
 
Thank you very much Kroum!

rob


Rafael
 
Hi Kroum
First of all, thanks for this great software.
I stopped at the same point that did worked for rob above, but not for me. Im trying to use a brazilian portuguese keyboard with an old DOS app.
When I reached this topic I had already done the exact same steps:
telnet.ini
export_code_page = 65001
Putty
translation characters: UTF-8
allusers.bat
added the command:
KB16 BR,850,C:\Windows\System32\KEYBOARD.SYS
(also tried simply chcp 850)

When Putty opens the console the keymapings are correct, I can use "?<>/\;.," keys all in the right places in keyboard. If I run KB16 it shows all maping is correct.
But when I lauch the DOS application, the keys get all messed up, the chars are all changed and some lost.
If I run the application directly in DOS prompt, either in the client or the server machine, it uses the correct keymapings.
What else can I do to correct this?


 

© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group