KpyM Telnet/SSH Server - Forum
public key
Anderson public key
how i can do to use a public key connection, i have a linux server and i like to conncet to windows and make some commands, for linux to linux i did using dsa public key, how i can do it?

Kroum Grigorov
1) use your client software to generate the private key file/public key file pair.
2) open your public key file with your favourite text editor, the public key file will look something like these:


3) take the public key part only(the selected text on the picture above) if it is on multiple lines, delete the new lines and convert it to one long line.

4) open c:\program files\kts\publickey_logon.ini file and fill in the public key(the long line from 3) and the user credentials(your windows login and pass) that the public key will map to.

; user #0
publickey0 =AAAAB3NzaC1kc3MAA...VixKU6sf==
username0 =jpdow
password0 =Ma1S1cretP@$$
domain0 =


I will try, thanks !!!

Hi All,

With this implementation, anybody can read user credentials !

Is there another implementation ?



Kroum Grigorov
>anybody can read user credentials !
Yep, anybody that has read access to the file.

> Is there another implementation ?
Nope, but you could easily hack your own implementation.


Thanks for your reply.


Adam Tauno Williams
I have this setup, and the client prompts me to unlock the public/private key, so I believe the key exchange is occurring. BUT on the client I am still prompted for a password.

I generate keys without (or blank) passprhase, but when I try to login I can't , I'm using rebex gui client example, any idea?

I seems that public key auth just work for ssh sessions not for sftp clients.

I mean, I connect using putty to start a session and it works perfectly, but when I use the rebex sftp client sample, dosn't work, not pretty sure about what I'm talking about it.

Well, it looks like a rebex problem, I've tested with other clients using private key auth and it worked (putty,winscp).

I'm not pretty sure what's exactly the problem, the rebex sample works fine just with username and password, and using private key I've just tested with a commercial server ServU and worked. I suppose is more like a compatibility problem between KTS/Rebex.

My regards and at any case, thx


© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group