KpyM Telnet/SSH Server - Forum
Can't use backspace!
Jan Can't use backspace!
Hi...I'm using PuTTy as an SSH client. What really annoys me though is that I cannot delete anything i typed.
So anything that Putty displays on the current command line can't be undone by pressing backspace. Whenever I misspell something i have to use enter, causing an "not found" error or whatever, and then i will have to retype it...

Any ideas?

Kroum Grigorov
You can either use ctrl+h instead backspace
or parameter PuTTy to send ctrl+h on backspace for you
see below:

Guest perfectly now.

One thing is still weird though...
When pressing backspace in, I get commas (",")...not a real problem because you can delete characters with the DEL key, but im just wondering...


Kroum Grigorov
Huh, is a tricky app.
Actually because of "", KTS implements backspace as left+del, so backspace acts a little stranger.
However, it "should" work well enough and you must not get commas or anything else when pressing backspace.
Might be there is some problem with KTS parameters.
Have you changed KTS default parameters?

Jan behaves like this:

You press backspace and it goes to the left once, and then inserts a comma. I have no idea why...I didn't change any parameters.

I guess I did something wrong again :) I'll play with it a little ... maybe i can figure it out.

Ah another thing: what's the deal with term-ssh.exe and term.exe? Would it be passible to change the code so that you don't need these extra files? Or can you use another command prompt instead of the windows port of bash?

Kroum Grigorov
telnetd.exe is a simple server process, all it does is to wait for incoming connection and then spawn one of the following files and pass the connection to it.
term.exe - that's the wrapper process for telnet connections it spawns the shell and handles the telnet input/output for the session.
term-ssh.exe - it's does the same as term.exe but for ssh connections

You will have one such process running for every active telnet/ssh session.

You can parameter the bash shell to start automatically by modifying "scripts/allusers.bat" file or "scripts/<username>.bat" file, if you want to start bash for given user only.

Add in it something like that:

rem the following script should start the bash for you
rem and add exit so that session is closed when bash is exited

Another solution is described here, look at points 2 and 3

Frank Quinn
I just added the entry for 127 to the ascii.ini file and replaced the other entry for it, then joined together the left and delete strokes. Dont know what else this will break (it corresponds to ctrl+?). If you want to see what you're actually pressing under linux, type showkey and type what you want to map!

This helps me.


© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group