KpyM Telnet/SSH Server - Forum
Far manager stopped working correctly
Max Far manager stopped working correctly

Once I installed Kpym, general command-line utilities and full-screen applications like far worked correctly both remotely and locally with putty properly configured. I have the following settings:
- in telnet.ini
export_code_page = 65001
- allusers.bat
chcp 1251
- in putty
- UTF-8

Recenly I tried to run far.exe and in stopped working properly (general command-line applications still work as expected). Symtoms are
- it shows cyrillic symbol and invalid symbols instead of pseudographics (no correct pseudographics visible at all)
- frequently redraws the screen bigger vertically than current putty window.
- Sometimes cursor movement (selection change in far that should change the layout of 10-30 symbols) changes only parts of the screen (as expected), sometimes it leads to big flow of symbols inside the terminal.
- Sometimes I see square symbols all over the area.

This is the same for remote and local work so unlikely putty loses some settings and it's the same when I restart the computer and Kpym service alone.

If it's necessary I can sen screenshot and other information.

Thank you,


Kroum Grigorov
Have you made any changes to KTS -or- your FAR manager?



the problem seems to self-solved, but after solving another problem.
I noticed according to the log that there are too much scanners were trying to connect through ssh so changed the port from 22 to another one. After this change the Fat started working correctly on all platforms. I'm not sure, but could this be due to some intervention from third party when my current session was active?


Kroum Grigorov
>some intervention from third party when my current session was active
Nope, there should be no impact on the sessions no matter how many scanners/sessions you have, unless your system is going low on resources this could lead to all sort of bizzare issues but I don't think this is the case.

If your scanners are shareing the same user/pass and you have disconnected sessions enabled then you might have many sessions started from one device and later connected to another. This sometimes corupts the session screen due to the differences in the client settings.



© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group