KpyM Telnet/SSH Server - Forum
Trying to use VNC via port forvarding
Antti Trying to use VNC via port forvarding
The SSH session works fine, but when I connect with RealVNC client to the local port that has been forwarded, I get this on the servers kts-log.txt:

login accepted: [ antti ]
begin port forward
create port forward channel 2 for 172.xx.xx.xx:5900
max_portforward_channels reached channel 2not created
close port forward channel 2
idle timeout
port forward end
session.exe end

I am trying to forward only one port to an other.


looking the source, I found that I was missing a parameter in kts.ini. When I added max_portforward_channels =3 in kts.ini [KSession] section, it started working.

Was it OK to do so?


Kroum Grigorov
Yep, my bad.
The max_portforward_channels parameter is missing in kts.ini file
You can just add this in [KSession] section.
This defines the max number of active portforward_channels per session

I'll fix this in the 1.17 setup package within a couple of days


another thing to do when using the portforwarding a bit longer is to set the idle timeout to zero. The original ssh session cannot be used while portforwarding is in use, so the idle timeout will close both channels when it goes off.



© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group