KpyM Telnet/SSH Server - Forum
Net::Telnet w/ KpyM
brian Net::Telnet w/ KpyM
We use the perl Net::Telnet package extensively, and I'm having trouble getting KpyM to work with it. It appears there are some escape characters at the end of the login prompt that the package doesn't recognize. Is there a way to turn this off?

Here is a hex dump from the login showing the bytes being sent to the client. It starts with some of the horizontal lines (====) in the default prompt:

< 0x000f0: 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d ================
< 0x00100: 3d 0d 0a 0d 0a 0d 0a 6c 6f 67 69 6e 3a 1b 5b 31 =......login:.[1
< 0x00110: 30 3b 38 66 1b 5b 31 30 3b 38 66 0;8f.[10;8f

Kroum Grigorov
You can suppress most of the control characters by setting [KSession] : pipe_mode = 1, but this will take effect only AFTER the user is logged in. So even with pipe mode on you will continue to receive escape characters at the login prompt.
You can have a look at this topic for hints on connecting to KTS

Also once you set pipe mode on the output will look quite distorted as this mode is intendet to be used for scripting only and not for human use.



© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group