KpyM Telnet/SSH Server - Forum
compiling on vista
sr compiling on vista
 
I'm trying to compile the kpym source on vista with visual c++ 2008 express edition.

compiling shlex gave me some issues.


In main(), I had to add the typecasts.

sei.lpFile = (LPCWSTR)argv[1];
sei.lpParameters = (LPCWSTR)argv[2];

Now get a linker warning -
shlex.obj : error LNK2019: unresolved external symbol __imp__ShellExecuteExW@4 referenced in function _main


This seems to suggest that vista SP1 is needed.
http://tinyurl.com/36drlh

I'm a little uncomfortable doing this just yet.
Would anyone have suggestions on how to get
past the linker error?

thanks,
-sr


Kroum Grigorov
 
Check the shlex project link parameters.
It should link towards shell32.lib to resolve ShellExecuteExW

Krum


mnjrupp ShellExecuteExW@4
 
I was getting the same linker error under VC++ express 2005 running on server 2003.
I had shell32.lib listed under linker parameters,but the box "Inherit from parent or project defaults" is not checked by default.
I checked it and the linker error went away.


 

© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group