KpyM Telnet/SSH Server - Forum
Connection closed by remote host
Daniel Berger Connection closed by remote host

I installed kpym 1.15c on a Win2k box and was able to connect to it just fine. Then I installed DynDNS, and now I get this error whenever I try to connect to the ssh server:

daniel-bergers-computer:~ djberge$ ssh -v -l rubygems
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /Users/djberge/.ssh/identity type -1
debug1: identity file /Users/djberge/.ssh/id_rsa type -1
debug1: identity file /Users/djberge/.ssh/id_dsa type -1
debug1: ssh_exchange_identification: Sep 8 12:00:10 klogd: klogd started: BusyBox v0.61.pre (2005.04.26-00:08+0000)

debug1: ssh_exchange_identification: Doing BRCTL ...

debug1: ssh_exchange_identification: setfilter br0 0

debug1: ssh_exchange_identification: /var/tmp/act_firewall: No such file or directory

debug1: ssh_exchange_identification: insmod: ipt_REJECT.o: no module by that name found

debug1: ssh_exchange_identification: msntp: too many bad or lost packets

ssh_exchange_identification: Connection closed by remote host

I tried uninstalling and reinstalling kpym after I had setup DynDNS, but that didn't help. I also tried connecting from another machine I have in the house with the same result.

Any ideas?



Kroum Grigorov

First make sure KTS is running on your Win2k box by trying "ssh localhost" on that machine. If you can log in then KTS is OK.

Check if your DynDNS client is set up correctly, check if it send your "real" IP to the DNS.

Check if you can ssh to your box by using its IP instead of host name.

Check if your box is not behind a firewall or router.


Daniel Berger
Hi Kroum,

I tried your suggestion. I'm able to 'ssh localhost', as well as ssh to my internal IP (192.168.x.x). I was not, however, able to ssh to my external IP.

I have DSL, connected through an Actiontec Gateway, btw. No firewall running afaik (Zone Alarm is shut down).

Where do I go from here? Is this a DynDNS config issue or a DSL issue? If so, I have no clue where to go from here.



Kroum Grigorov
> I was not, however, able to ssh to my external IP

It looks to me like some config problem in your LAN.
Make sure you have correctly configured some port forwarding between your external IP(I assume that's your DSL device) and your internal IP(that should be your Win2k box)

Refer to your DSL device manual for more info on how to configure port forwarding.


Nicolas You have a modem-router ?
Hello, sorry for my english my native language is spanish. I think that you have a modem-router, that you DON'T configure to forward de ssh port (22). And, when you try to connecto to your win server box by de Dyndns domain. Really you connecto to the modem-router box.

nicolas.ard (at)


© 2007 - 2008 Kroum Grigorov
Powered by phpBB © 2001, 2005 phpBB Group